OpenSSL Compatibility

Allegro CL and products built on it, such as AllegroGraph, cannot currently use OpenSSL 1.1. They require OpenSSL 1.0.x. A patch will soon be released which allows using either version. We will update this page when that release has been made generally available.

Below is a list of operating systems which natively support OpenSSL 1.0.x. Until we provide a patch to support OpenSSL 1.1, please use one of these versions, if you would like to use Allegro CL or AllegroGraph. In the case of AllegroGraph, a new release will be required, once the patch is available in Allegro CL.

  • RHEL/CentOS:
    • 7.x: the latest version with OpenSSL 1.0.x.
    • 6.x: OpenSSL 1.0.x.
  • Ubuntu: 16.04 LTS (Xenial Xerus) is the last version with OpenSSL 1.0.x
  • Debian: 8 (jessie) is the last version with OpenSSL 1.0.x
  • macOS: we rely on the MacPorts version of OpenSSL on this platform, and version 1.0.x and 1.1.x are available. The port names are openssl or openssl10 for 1.0.x.
  • FreeBSD: 11.x was the last version with OpenSSL 1.0.x.
  • Solaris: we do not use native builds of OpenSSL on this platform.
  • Windows: we do not use native builds of OpenSSL on this platform.
For Linux-based operation systems, older versions than listed above will often work, assuming they meet the minimum glibc library requirements, listed on the download page for Allegro CL.

Copyright © 2019 Franz Inc., All Rights Reserved | Privacy Statement Twitter Google+