IDE DialogToCDocOverviewCGDocRelNotesFAQIndexPermutedIndex
Allegro CL version 8.1
Unrevised from 8.0 to 8.1.
8.0 version

Menu Editor

The menu editor allows you to design menus for Window menu bars. It does not support designing of pop-up menus.

This is a modal dialog. You must click on OK or Cancel (or click on the close box, equivalent to Cancel) before doing anything else in the IDE.

This dialog is displayed in two ways.

  1. From the Inspector window inspecting a form. Click on the extended editor button in the menu field when a form is inspected.
  2. Using the Edit Menu Bar menu command on the Form menu. This command will only be present when the current form already has a menu bar. If the current form does not have a menu bar, Add Menu Bar will be on the Form menu. Choose that to add a menu bar. Doing so also displays the Menu Editor dialog.

Menu bars can be removed from a form by making the value of the menu property nil (using the Inspector) or by choosing Form | Remove Menu Bar.

Menus are displayed using an outline control. The first level (all the way to the left) identifies menus on the menu bar. An item in an indented level is either a menu-item (if it is a leaf in the outline) or a submenu (if the item itself has subitems). Clicking right on a value in this outline now selects the value and shows a shortcut menu of appropriate commands for it.

The remainder of the dialog has the following fields and components.

The default menus

The default menu-bar that gets attached by the inspector to a form calls four sample functions from its File menu. These functions are exported, but are not available at runtime since a real application would want to implement its own custom version of these functions. The sources are given in the Help page for these default functions, to assist developers in writing their own functions.

(Note that the default Edit menu items for cutting and pasting are useful as is at runtime and so are available in runtime.)

The functions are:


Copyright (c) 1998-2009, Franz Inc. Oakland, CA., USA. All rights reserved.
Documentation for Allegro CL version 8.1. This page was not revised from the 8.0 page.
Created 2009.7.29.

ToCDocOverviewCGDocRelNotesFAQIndexPermutedIndex
Allegro CL version 8.1
Unrevised from 8.0 to 8.1.
8.0 version