AllegroGraph 3.3 FAQ

[Last updated on: 2014-11-11T10:01:44+8:00.]

For Allegrograph 4.x information, please refer to the 4.0 documentation

This is a list of frequently asked questions on the use of AllegroGraph. Each question applies to all currently supported versions unless otherwise noted with version specific information.

Please read this document before sending mail reporting problems to support@franz.com.

Getting Started

How is the AllegroGraph product structured?

AllegroGraph RDF Store is either licensed separately as a Server/Client architecture or can be utilized standalone within a full Common Lisp development environment. For each edition of AllegroGraph, there is a free version; Free (up to 50 million triples), and two commercial versions; Developer (up to 600 million triples) and Enterprise (unlimited triples).

What is the current version of AllegroGraph?

The current version of AllegroGraph 3 is 3.3. AllegroGraph 4 is also available on some platforms. See this page for more details.

Downloading AllegroGraph

How do I get the Free Edition?

You can download the Free Editions from: /agraph/downloads/

How do I get the Enterprise Edition?

When you have purchased either the Developer or Enterprise Edition of AllegroGraph, you will be provided with ftp instructions for downloading the software. If you have special evaluation requirements that cannot be met with the Free Edition, please contact sales@franz.com

How do I get the Free Lisp Edition if I am an ACL Professional or Enterprise Edition customer?

Your ACL 8.1 license file includes the AllegroGraph Free Lisp Edition license. You can download the software from: http://www.franz.com/downloads/clp/agle_survey

If you have an earlier version of ACL and would like to upgrade, please contact sales@franz.com

How do I get the Free Lisp Edition if I am an ACL Express Edition user?

You will first need to download and install the ACL Express Edition. You can get that from here.

Then you can download the Free Lisp Edition from: http://www.franz.com/downloads/clp/agle_survey

How do I get the Lisp Edition if I am an ACL Enterprise Edition Customer?

Once you have purchased AllegroGraph Lisp Edition, you will receive the appropriate Developer or Enterprise license via email. You can then download the Lisp Edition from: http://www.franz.com/products/allegrograph/download/dist/download

How do I get the Lisp Edition if I am an ACL Professional Edition Customer?

The AllegroGraph Lisp Edition requires the ACL Enterprise Edition. You will need to upgrade your license and can do that by contacting sales@franz.com.

Installation

How do I install the AllegroGraph Server?

Once you have downloaded the correct version for your platform, installation is easy. It is described in the beginning of the AllegroGraph Server Installation guide. You can find that here: /agraph/support/documentation/3.3/server-installation.html

How do I install the Free Lisp Edition (Standalone)?

Once you have ACL installed on your system and downloaded the correct version of AllegroGraph for your platform, installation is easy. The installation instructions are described on the AllegroGraph download page. http://www.franz.com/downloads/clp/agle_survey

How do I install the Lisp Edition (Standalone)?

Once you have ACL installed on your system and downloaded the correct version of AllegroGraph for your platform, installation is easy. The installation instructions are described on the AllegroGraph download page. http://www.franz.com/products/allegrograph/download/dist/download

How do I use Lisp as a Client to the AllegroGraph Server?

Once you have installed a Lisp Edition as described above, follow the instructions in this document: Lisp Client API to Remote AllegroGraph

Patches

How do I install patches to AllegroGraph?

Instructions for installing AllegroGraph patches are described on this web page: http://www.franz.com/agraph/support/patches/

General Use

How do I get started when I'm a Java programmer?

To best way to understand the big picture regarding AllegroGraph is to read the AllegroGraph Introduction document. It provides an overview of what AllegroGraph does and how to use it. /agraph/support/documentation/3.3/agraph-introduction.html

Next, refer to the AllegroGraph documentation, looking at the Java section in the index here: /agraph/support/documentation/3.3/index.html.

There is a Learning Center that has example code for all of the various aspects of AllegroGraph located here: /agraph/support/learning/.

You can also watch our recorded web seminars here: /services/conferences_seminars/

How do I get started when I'm a Lisp programmer?

To best way to understand the big picture regarding AllegroGraph is to read the AllegroGraph Introduction document. It provides an overview of what AllegroGraph does and how to use it. /agraph/support/documentation/3.3/agraph-introduction.html

Next, refer to the AllegroGraph Tutorial. /agraph/support/documentation/3.3/agraph-tutorial.html

You can also watch our recorded web seminars here: /services/conferences_seminars/

Is the AllegroGraph documentation available on-line?

Yes, there is a Documentation section on the AllegroGraph products page that has links to the documentation and tutorials on SPARQL, Prolog, and the AllegroGraph Reasoner, see here: /agraph/support/documentation/3.3/index.html

Do you support RDF/XML?

Yes. You load data into AllegroGraph from RDF files. Currently we support as input RDF/XML and N-Triple formats. If you have another format such as Turtle, we advise you to use the open source tool Rapper (the Raptor RDF parser utility 1) to convert it to N-Triples. We will be supporting RDF/XML in the next release coming soon.

For more information, see the following: N-Triples RDF/XML Turtle and Rapper

How do I use Rapper and where do I find it?

Rapper is one of the Raptor RDF tools that are part of Redland, a set of free software libraries that provide support for the Resource Description Framework (RDF). See the project website for more details and additional tools. http://librdf.org/

Administrative Issues

How can I back up AllegroGraph data?

There are 3 ways:

1. If you want to dump the triples to an ascii file in ntriples format you just can do:

(defun dump (name)
 (with-open-file (out name :direction :output :if-exists :supersede)
   (print-triples (get-triples) :format :ntriple  :stream out :limit nil)))
    

The advantage of this approach is that you output valid RDF ntriples. The disadvantage is that you lose the named graphs and encoded triples.

2. Another human-readable format which does preserve named graphs is TriX:

(with-open-file (out name :direction :output :if-exists :supersede)
  (db.agraph.serializer:serialize-trix *db* out))
    

3. A binary dump can be done by copying the entire database directory minus all the files that start with index. You could save the index files too but those can always be regenerated again.

TopBraid Composer

How do I install TopBraid Composer?

To install TopBraid Composer, download it and follow the installation instructions from here: http://www.topquadrant.com/topbraid/composer/download.html

How do I update my TopBraid Composer to the latest version?

If you already have it installed but want to check for updates, start TopBraid Composer, then under the Help menu, select Software Update. Select the TopBraid Composer Update Site box and click on Finish.

I want to use TopBraid Composer with the Java Edition of AllegroGraph, how do I get started?

TopBraid Composer communicates with AllegroGraph through a server. You first need to install both products. Make sure you have the latest version of TopBraid Composer and all of the patches installed in AllegroGraph. (described in other FAQ answers).

First start the AllegroGraph Server. The Java Edition is distributed with an executable that starts a server when it is run. If you are running on a Windows operating system, go to Start Menu > All Programs > AllegroGraph Free Java Edition > Start AllegrGraph Free Java Edition Server. This will start the server.

More detailed information on the AllegroGraph server, including other operating systems can be found here: /agraph/support/documentation/3.3/server-installation.html#agraph-server

Then, in TopBraid Composer, select File > New > OWL/RDFS AllegroGraph Database.

Fill in the File name and AllegroGraph database name, both with the name you want to call the database, eg: agdb1 for both entries.

Fill in the AllegroGraph directory with the directory name, eg: C:\temp\agraph\.

The default Host: localhost and Port: 4567 should be ok as is.

Select Finish.

A new entry called adgb1.allegro will appear in the Navigator Place. You now have an AllegroGraph database open. To test, try loading an ontology, for example the pizza ontology. Under the imports tab in the lower center window, click on the icon with a plus symbol over a globe icon to import from a URL, then type or paste in: http://www.co-ode.org/ontologies/pizza/2007/02/12/pizza.owl. You should see new pizza related properties appear in the upper right.

For further instructions, please refer to the TopBraid Composer documentation for importing and working with your data.

I want to use TopBraid Composer with the Lisp Edition of AllegroGraph, how do I get started?

TopBraid Composer communicates with AllegroGraph through a server. You first need to install both products. Make sure you have the latest version of TopBraid Composer and all of the patches installed in AllegroGraph. (described in other FAQ answers).

First start the AllegroGraph Server. The Lisp editions support the AllegroGraph server in the agraph module. This module includes the function start-agj-server. This function starts the server that allows TBC to access AllegroGraph. At the lisp prompt, after you have loaded AllegroGraph:

CG-USER(1) (require :update)

CG-USER(2) (system.update:install-allegrograph)

CG-USER(3) (require :agraph)

type the following:

CG-USER(4): (in-package #:db.agraph.user) ; to specify the right package, then type

TRIPLE-STORE-USER(5): (start-ag-server) ; to run the function and start the server

More detailed information on the AllegroGraph server can be found here, find the function name: /agraph/support/documentation/3.3/reference-guide.html

Then, in TopBraid Composer, select File > New > OWL/RDFS AllegroGraph Database.

Fill in the File name and AllegroGraph database name, both with the name you want to call the database, eg: agdb1 for both entries.

Fill in the AllegroGraph directory with the directory name, eg: C:\temp\agraph\.

The default Host: localhost and Port: 4567 should be ok as is.

Select Finish.

A new entry called adgb1.allegro will appear in the Navigator Place. You now have an AllegroGraph database open. To test, try loading an ontology, for example the pizza ontology. Under the imports tab in the lower center window, click on the icon with a plus symbol over a globe icon to import from a URL, then type or paste in: http://www.co-ode.org/ontologies/pizza/2007/02/12/pizza.owl. You should see new pizza related properties appear in the upper right.

For further instructions, please refer to the TopBraid Composer documentation for importing and working with your data.

Working with Sesame

Do you have any examples for adding triples over the Sesame 2.0 HTTP server interface?

The simplest way is to add triples one at a time specifying the subject, predicate, object, and optionally the context in the request URI. If a default server is running at localhost port 8123, then the request to update the store with id tsname would be of the form:

PUT: http://localhost:8123/sesame/repositories/tsname/statements?subj=sss&obj=ooo&pred=ppp

where sss, ppp and ooo are uri-encoded ntriples representations of the subject predicate and object of the triple.

If the subject is the URI http://app.org/foo#subject then the ntriples notation is <http://app.org/foo#subject> and the uri-encoding is:

%3chttp%3a%2f%2fapp.org%2ffoo%23subject%3e

Though there is no example of RDF/XML included here, other variations of the update request can be used to specify the triples as RDF/XML in the content of the request, or as XML transactions in the content of the message:

POST: http://localhost:8123/sesame/repositories/tsname/statements


   content-type = application/x-rdftransaction

   content:
   <transaction>
      <add>
       <uri>http://app.org/foo#subject</uri>
       <uri>http://app.org/foo#predicate</uri>
       <literal>abcdefg</literal>
      </add>
   </transaction>
    

Java applications can use the Sesame 2.1 Sail API to access an AllegroGraph triple store by instantiating the AllegroSail implementation class.

Copyright © 2014 Franz Inc., All Rights Reserved | Privacy Statement
Delicious Google Buzz Twitter Google+